Incoming calls do not connect
Incident Report for Merinio
Resolved
This incident has been resolved.
Posted Feb 17, 2020 - 21:49 EST
Monitoring
Incoming calls for most phone numbers is back to normal operation, we will continue to monitor the situation.
Posted Feb 17, 2020 - 16:50 EST
Update
Our provider has updated their status page and we are awaiting further news.

https://status.twilio.com/incidents/6gd7kdy789l3
Posted Feb 17, 2020 - 16:49 EST
Identified
Incoming calls do not currently connect on some networks. We have identified the source upstream of our voice provider and will communicate news as we receive it.
Posted Feb 17, 2020 - 16:15 EST