Web application and mobile fail to load
Incident Report for Merinio
Postmortem

Root Cause Analysis:
The core issue was traced back to an overlooked renewal of the SSL certificate. Essential renewal notifications were inadvertently directed to our spam folder, resulting in a missed update of the certificate. This oversight led to the service interruption experienced by our users.

Impact:
During the disruption, users encountered difficulties in accessing our services. We acknowledge the inconvenience caused by this incident and deeply regret the impact on our users' experience.

Resolution and Prevention:
Upon identification of the root cause, we have implemented a shift to DNS validation for future SSL certificate renewals. This change introduces a fully automated process, significantly reducing the likelihood of similar incidents in the future.

Posted Jan 05, 2024 - 09:38 EST

Resolved
At approximately 7:00 PM today, we experienced an unexpected disruption in our services due to an expired SSL certificate. Our monitoring systems alerted us to the issue, and our team immediately began investigating.

The issue was identified as a missed renewal of the SSL certificate. The renewal notification was mistakenly routed to our spam folder, leading to an oversight in the certificate's renewal.

During this period, users may have experienced difficulty accessing our services. We understand the inconvenience this caused and are taking steps to prevent a recurrence.
Posted Jan 04, 2024 - 19:00 EST