Page styling on some devices does not render correctly.
Incident Report for Merinio
Resolved
This incident has been resolved.
Posted 6 months ago. Jan 06, 2019 - 19:58 EST
Identified
The issue has been identified and a fix is being implemented.
Posted 6 months ago. Jan 06, 2019 - 19:57 EST
This incident affected: Web Application.