Generally slow page loads
Incident Report for Merinio
Resolved
We've found the source of this incident and are working on a fix, but it should no longer occur for now.
Posted 3 months ago. Apr 16, 2019 - 17:29 EDT
Investigating
We are currently investigating an issue where the API takes several times longer to respond to requests than usual.
Posted 3 months ago. Apr 16, 2019 - 17:07 EDT
This incident affected: Web Application and API.